Ontology update: sioc:WebService, etc.

Hi All,

There's a new version (v1.11) of SIOC specification online at
http://rdfs.org/sioc/spec/ .
It contains definition for sioc:WebService discussed in [1].

[1] http://groups.google.com/group/sioc-dev/browse_thread/thread/63c1000e086ed370

There are some comments in the last posts of the thread that I am
implementing now and will have those online tomorrow.

One of things to clarify is the service protocol / type / access_level
stuff. I get a feeling that we are going into too much detail in some
parts - at least when it comes to specifying read/write/delete
capabilities.

Propose we use sioc:service_protocol for the transport protocol (SOAP
/ XML-RPC / REST). If we use this property to say if its SPARQL /
GData / etc. we risk confusion between SPARQL query language and
protocol itself.

Could we use sioc:query_language to specify SPARQL / GData /
OpenSearch / ... ? Or sioc:application_protocol for this and
sioc:transport_protocol for [ SOAP / XML-RPC / REST ] ?

Best,
Uldis

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "SIOC-Dev" group.
To post to this group, send email to sioc-dev@googlegroups.com
To unsubscribe from this group, send email to sioc-dev-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/sioc-dev?hl=en
-~----------~----~----~----~------~----~------~--~---

Ontology update: sioc:WebService, etc.

Great stuff, just one small change I made is to Webservice as discussed
previously.

I think the idea of a sioc:query_language is better than
application_protocol which could be more than just a query language.
But similarly, service_protocol is quite general as well...

So how about something in between your two proposals Uldis:

sioc:transport_protocol
sioc:query_protocol

?

J.
--
Uldis Bojars wrote:
> Hi All,
>
> There's a new version (v1.11) of SIOC specification online at
> http://rdfs.org/sioc/spec/ .
> It contains definition for sioc:WebService discussed in [1].
>
> [1] http://groups.google.com/group/sioc-dev/browse_thread/thread/63c1000e086ed370
>
> There are some comments in the last posts of the thread that I am
> implementing now and will have those online tomorrow.
>
> One of things to clarify is the service protocol / type / access_level
> stuff. I get a feeling that we are going into too much detail in some
> parts - at least when it comes to specifying read/write/delete
> capabilities.
>
> Propose we use sioc:service_protocol for the transport protocol (SOAP
> / XML-RPC / REST). If we use this property to say if its SPARQL /
> GData / etc. we risk confusion between SPARQL query language and
> protocol itself.
>
> Could we use sioc:query_language to specify SPARQL / GData /
> OpenSearch / ... ? Or sioc:application_protocol for this and
> sioc:transport_protocol for [ SOAP / XML-RPC / REST ] ?
>
> Best,
> Uldis
>
> >
>
>
>

--
Dr. John Breslin
DERI, NUI Galway
http://sw.deri.org/~jbreslin/
john.breslin@deri.org

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "SIOC-Dev" group.
To post to this group, send email to sioc-dev@googlegroups.com
To unsubscribe from this group, send email to sioc-dev-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/sioc-dev?hl=en
-~----------~----~----~----~------~----~------~--~---

Ontology update: sioc:WebService, etc.

On 12/13/06, John Breslin wrote:
>
> Great stuff, just one small change I made is to Webservice as discussed
> previously.

Both uses were mentioned - Webservice and WebService.
"Web service" is two words, that's why 2nd naming is more natural.
Don't you agree?

FOAF also has names like OnlineAccount and PersonalProfileDocument. If
those had only the 1st capital letter they'd be quite unreadable.

Suggest we use (and come up with) a class naming convention for
multi-word classes. We have a convention for properties (to use "_" to
separate words) but we had never used it for classes.

We also need to describe a naming convention in the specification.

> I think the idea of a sioc:query_language is better than
> application_protocol which could be more than just a query language.
> But similarly, service_protocol is quite general as well...
>
> So how about something in between your two proposals Uldis:
>
> sioc:transport_protocol
> sioc:query_protocol

Good idea! :)

The only word I am still unsure about is "query" - if we are talking
about read/write services that can do inserts and deletes then it's
not only about querying. Though SQL is a query language as well and
yet allows updates and what-not. So let's have sioc:query_protocol
unless there are objections against it.

Uldis

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "SIOC-Dev" group.
To post to this group, send email to sioc-dev@googlegroups.com
To unsubscribe from this group, send email to sioc-dev-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/sioc-dev?hl=en
-~----------~----~----~----~------~----~------~--~---

Ontology update: sioc:WebService, etc.

> Both uses were mentioned - Webservice and WebService.
> "Web service" is two words, that's why 2nd naming is more natural.
> Don't you agree?

You're right, let's come up with a convention for multi-word things
like Bulletin Board, Mailing List, etc. (I was treating webservice as
a single word like webmaster or website)...

Thanks,

John.
--

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "SIOC-Dev" group.
To post to this group, send email to sioc-dev@googlegroups.com
To unsubscribe from this group, send email to sioc-dev-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/sioc-dev?hl=en
-~----------~----~----~----~------~----~------~--~---